Fix Error: Изглежда, че във вашата PHP инсталация липсва разширението MySQL, което се изисква от WordPress

"Изглежда, че във вашата PHP инсталация липсва разширението MySQL, което се изисква от WordPress„Грешка е много от собствениците на блогове и уебсайтове WordPress.
Това не е причина за безпокойство. Липса на MySQL разширение от PHP е типично за операционни системи, инсталирани от нулата, VPS или специализирани сървъри, където разширенията на PHP не са били част от инсталационния пакет. Този проблем е налице и при двете Ubuntu и CentOS, В този сценарий проблемът се решава много просто с актуализация на PHP и инсталиране на модул "PHP-MySQL".
Актуализирайте PHP и инсталирайте MySQL разширение в Ubuntu

apt-get update
apt-get install php-mysql

Актуализирайте PHP и инсталирайте MySQL разширение на CentOS

yum update
yum install php70w-mysql

След тази стъпка, рестартирайте услугата Apache или Nginx.

Срещнах и сценария, при който, въпреки че MySQL разширението съществува в PHP, в блога, създаден на WordPress, се появи грешката „Изглежда, че във вашата PHP инсталация липсва разширението MySQL, което се изисква от WordPress“. През повечето време грешката възниква при инсталирането на WordPress. Този път обаче той се появи в блог, който беше активен от няколко години.
В тази ситуация открих, че проблемът не са PHP модулите, а много старата версия на WordPress, която вече не е съвместима с PHP 7.4.4RC1. Проста надстройка на WordPress до най-новата версия реши грешката.

Fix Error: Изглежда, че във вашата PHP инсталация липсва разширението MySQL, което се изисква от WordPress

За автора

Хитрост

Страстен за всичко, което означава джаджа и IT, с удоволствие пиша на stealthsettings.com от 2006 и обичам да откривам нови неща за компютрите и macOS, Linux операционните системи, Windows, iOS и Android.

Оставете коментар